Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 1 day agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square20fedilinkarrow-up167arrow-down19cross-posted to: [email protected]
arrow-up158arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 1 day agomessage-square20fedilinkcross-posted to: [email protected]
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up10arrow-down1·18 hours agoBalls.suck() is the correct syntax.
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up2·6 hours agoActually, it would be OOP.suck(ddplf.getBalls())
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up4·18 hours agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up9·edit-25 hours agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up6·edit-212 hours agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up9·12 hours agoPython port: from ballsucker import suck suck()
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·18 hours agoOr I didn’t using the correct naming convention!
Balls.suck() is the correct syntax.
Actually, it would be
OOP.suck(ddplf.getBalls())
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!